Author Topic: Process Lasso Not Staying In Bitsum HP Mode  (Read 1816 times)

Offline Jdawg Jdawg

  • New
  • *
  • Posts: 8
  • Gender: Male
Process Lasso Not Staying In Bitsum HP Mode
« on: November 21, 2018, 04:56:03 AM »
Hello,

I use Process Lasso when gaming. In particular, X-Plane 11 is selected as a Bitsum Hi Perf (BHP) .exe process. Process Lasso starts out in BHP but drops to Windows Default of High Performance Mode before I can begin to play.
This happens in both VR mode and Normal gameplay mode. I have changed numerous other application .exe to BHP with no change. Below is brief log. Thank you.

11-21-2018 17:42:33","mixedrealityportal.brokered.exe","13112","Active power plan changed","Per request of process default the power plan is now Bitsum Highest Performance","Evermore","Evermore","c:\program files\windowsapps\microsoft.mixedreality.portal_2000.18100.1171.0_x64__8wekyb3d8bbwe\mixedrealityportal.brokered.exe",""C:\Program Files\WindowsApps\Microsoft.MixedReality.Portal_2000.18100.1171.0_x64__8wekyb3d8bbwe\MixedRealityPortal.Brokered.exe" /InvokerPRAID: App"
"11-21-2018 17:42:33","environmentsapp.exe","13108","Active power plan changed","Per request of process default the power plan is now Bitsum Highest Performance","Evermore","Evermore","c:\windows\systemapps\environmentsapp_cw5n1h2txyewy\environmentsapp.exe",""C:\WINDOWS\SystemApps\EnvironmentsApp_cw5n1h2txyewy\EnvironmentsApp.exe" -ServerName:EnvironmentsApp"
"11-21-2018 17:42:33","mixedrealityportal.exe","3848","Active power plan changed","Per request of process default the power plan is now Bitsum Highest Performance","Evermore","Evermore","c:\program files\windowsapps\microsoft.mixedreality.portal_2000.18100.1171.0_x64__8wekyb3d8bbwe\mixedrealityportal.exe",""C:\Program Files\WindowsApps\Microsoft.MixedReality.Portal_2000.18100.1171.0_x64__8wekyb3d8bbwe\MixedRealityPortal.exe" -ServerName:App.AppXzx40k3w1n68mndcqd37444jvdx94yw14.mca"
"11-21-2018 17:42:33","holoshellapp.exe","3560","Active power plan changed","Per request of process default the power plan is now Bitsum Highest Performance","Evermore","Evermore","c:\windows\holoshell\holoshellapp.exe",""C:\WINDOWS\HoloShell\HoloShellApp.exe" -ServerName:HoloShell.AppXrewemkyw19fpgewe0e3191tzwcxka2x8.mca"
"11-21-2018 17:42:30","processgovernor.exe","14300","Automatic Performance Mode OFF","Automatic Performance Mode was turned off because no specified game processes are still running.","Evermore","Evermore","c:\program files (x86)\google\chrome\application\chrome.exe",""C:\Program Files (x86)\Google\Chrome\Application\chrome.exe" --type=crashpad-handler "--user-data-dir=C:\Users\Owner\AppData\Local\Google\Chrome\User Data" /prefetch:7 --monitor-self-annotation=ptype=crashpad-handler "--database=C:\Users\Owner\AppData\Local\Google\Chrome\User Data\Crashpad" "--metrics-dir=C:\Users\Owner\AppData\Local\Google\Chrome\User Data" --url=https://clients2.google.com/cr/report --annotation=channel= --annotation=plat=Win64 --annotation=prod=Chrome --annotation=ver=70.0.3538.102 --i"
"11-21-2018 17:42:30","x-plane.exe","14152","Automatic Performance Mode OFF","Automatic Performance Mode was turned off because no specified game processes are still running.","Evermore","Evermore","c:\program files\x-plane 11\x-plane.exe",""C:\Program Files\X-Plane 11\X-Plane.exe" "
"11-21-2018 17:42:30","processgovernor.exe","14152","Active power plan changed","Per request of process default the power plan is now Bitsum Highest Performance","Evermore","Evermore","",""
"11-21-2018 17:42:30","vrcompositor.exe","5844","Active power plan changed","The process terminated so the previous power plan of Bitsum Highest Performance has been enacted.","Evermore","Evermore","c:\program files (x86)\steam\steamapps\common\steamvr\bin\win64\vrcompositor.exe",""C:\Program Files (x86)\Steam\steamapps\common\SteamVR\bin\win64\vrcompositor.exe" "
"11-21-2018 17:30:26","vrmonitor.exe","11576","Active power plan changed","Per request of process default the power plan is now Bitsum Highest Performance","Evermore","Evermore","c:\program files (x86)\steam\steamapps\common\steamvr\bin\win64\vrmonitor.exe",""C:\Program Files (x86)\Steam\steamapps\common\SteamVR\bin\win64\vrmonitor.exe" -nokillprocess"
"11-21-2018 17:30:24","vrcompositor.exe","5844","Active power plan changed","Per request of process default the power plan is now Bitsum Highest



Offline edkiefer

  • Volunteer User Moderator
  • Member#
  • *****
  • Posts: 1669
  • Gender: Male
Re: Process Lasso Not Staying In Bitsum HP Mode
« Reply #1 on: November 21, 2018, 07:15:28 AM »
Thanks for the report, at a quick glance I think we know about this one and are investigating a fix.

The issue is PL is getting confused because of multiple performance mode and application power plan processes running the same time and one terminating causing PL to drop back to the wrong plan.
For now, try limiting processes to one type of trigger.
Bitsum QA Engineer

Offline Jeremy Collake

  • Administrator
  • Member#
  • *****
  • Posts: 5232
  • Gender: Male
  • The Lasso
    • Bitsum
Re: Process Lasso Not Staying In Bitsum HP Mode
« Reply #2 on: November 21, 2018, 08:14:18 PM »
I am not certain this is the same as the issue Ed mentioned.

There may be some other application that is changing power plans.

My recommendation would be to try turning on Forced Mode in the Options menu.

If you are curious what else may be impacting the active power plan, you can install ParkControl (https://bitsum.com/parkcontrol/) and enable the Power Plan Change Notifications.
« Last Edit: November 21, 2018, 10:49:01 PM by Jeremy Collake »
Software Engineer. Bitsum LLC.

Offline Jdawg Jdawg

  • New
  • *
  • Posts: 8
  • Gender: Male
Re: Process Lasso Not Staying In Bitsum HP Mode
« Reply #3 on: November 21, 2018, 11:35:22 PM »
Good day,

Thank you for your kind replies. I have extensively explored any Power Management or Tweaking software and I have none installed.

FORCED MODE apparently keeps power plan at BHP but my game crashes.

I installed CORE PARK (CP), however, I do not see the advantage of being notified when the power plan changes as I usually use the Power Options to determine this. Does CP record reasons for the power profile changes?

Thank you

Offline Jdawg Jdawg

  • New
  • *
  • Posts: 8
  • Gender: Male
Re: Process Lasso Not Staying In Bitsum HP Mode
« Reply #4 on: November 21, 2018, 11:41:18 PM »
Sorry but SYSTEM SPECS are as follows...

Alienware 17 R4
Operating System
Microsoft Windows 10 Pro (64-bit) 1809

Processor
Intel® Core™ i7-7700HQ CPU @ 2.80GHz

Graphics
Intel® HD Graphics 630
NVIDIA GeForce GTX 1070

Audio
Intel® Display Audio
USB Audio Device Realtek Audio

Networking and I/O
TAP-Windows Adapter V9
Killer Wireless-n/a/ac 1535 Wireless Network Adapter
Killer E2500 Gigabit Ethernet Controller

Memory 16 GB

Storage
SanDisk X400 M.2 2280 128GB
Samsung SSD 850 EVO 500GB

Offline Jdawg Jdawg

  • New
  • *
  • Posts: 8
  • Gender: Male
Re: Process Lasso Not Staying In Bitsum HP Mode
« Reply #5 on: November 22, 2018, 12:08:18 AM »
UPDATE: FORCED MODE Does not keep BHP enabled. Reverts to Windows HP mode.

Offline Jeremy Collake

  • Administrator
  • Member#
  • *****
  • Posts: 5232
  • Gender: Male
  • The Lasso
    • Bitsum
Re: Process Lasso Not Staying In Bitsum HP Mode
« Reply #6 on: November 22, 2018, 12:32:03 AM »
After reviewing your log more closely, maybe Ed's first instinct was right. Assuming that, please give me time to address this. I will get to it ASAP.

In the meantime, you can try this (UPDATE: see alternate suggestion first in next post):

1. Exit Process Lasso, being sure to close the core engine (processgovernor.exe) too when asked
2. Enter 'Bitsum Highest Performance' power plan manually
3. Restart Process Lasso

Hopefully that will cause it to always stay in BHP. You can optionally use IdleSaver if you want to lower to some more conservative power plan on idle.

Forced mode surely did not cause that crash, but if it doesn't help, then it is not worth using.

Quote
I installed CORE PARK (CP), however, I do not see the advantage of being notified when the power plan changes as I usually use the Power Options to determine this. Does CP record reasons for the power profile changes?

It is irrelevant now, as I know you've already checked for any other power software, but the 'power plan change notifications' notify you of what process changed/switched the active power plan (e.g. from 'Bitsum Highest Performance' to 'Highest Performance').
« Last Edit: November 22, 2018, 01:17:42 AM by Jeremy Collake »
Software Engineer. Bitsum LLC.

Offline Jeremy Collake

  • Administrator
  • Member#
  • *****
  • Posts: 5232
  • Gender: Male
  • The Lasso
    • Bitsum
Re: Process Lasso Not Staying In Bitsum HP Mode
« Reply #7 on: November 22, 2018, 01:17:10 AM »
Alternative suggestion based on the premise that the order of processes exiting is causing the reversion of the power plan:

1. Uncheck 'Performance Mode settings/ Attempt automatic game detection'
2. Remove all your custom application power plan rules and any Performance Mode classifications (clear all in 'Options / Configure application power profiles' and Options / Performance Mode settings / Designate High Performance processes'.
3. Right-click on the xplane process and select 'Induce Performance Mode'

That should reduce the confusion and contention with these rules.
Software Engineer. Bitsum LLC.

Offline Jdawg Jdawg

  • New
  • *
  • Posts: 8
  • Gender: Male
Re: Process Lasso Not Staying In Bitsum HP Mode
« Reply #8 on: November 22, 2018, 01:50:20 AM »
Sir,

First, I rebooted and ran X-Plane with Core Parking (CP) enabled. After several tests, I agree that did not cause the crash. i think I clicked so much that I induced my own crash. Apologies.

After following your advice of cleaning up, BHP mode activated as usual but it still switch back to Windows HP mode within a few minutes.

At first I thought it was Windows Game Bar (WGB) but the power switch occurs with WGB disabled. WGB has no power management functions that I am aware of. I have no other performance software installed.

Unrelated: Kindly email me a LINK to upgrade my GIVEAWAY OF THE DAY Process Lasso to Pro permanent and not the renewal.

Thank you for your kind and prompt reply.

Offline edkiefer

  • Volunteer User Moderator
  • Member#
  • *****
  • Posts: 1669
  • Gender: Male
Re: Process Lasso Not Staying In Bitsum HP Mode
« Reply #9 on: November 22, 2018, 07:48:40 AM »
Ok, To try an focus on what causes this, try this.
Shutdown PL, make sure both processes are closed.
Now change power plan to BHP, you can do it in windows power plan setting.

Does Xplane now stick to BHP while running?

Bitsum QA Engineer

Offline Jdawg Jdawg

  • New
  • *
  • Posts: 8
  • Gender: Male
Re: Process Lasso Not Staying In Bitsum HP Mode
« Reply #10 on: November 22, 2018, 08:36:33 AM »
Good day sir,

Following your directions, I disabled Pro Balance and PL from startup, , rebooted, verified Task Manager no PL processes, switched to BHP, started Xplane and Yes, Windows switched from BHP to Windows HP still. It did not remain in BHP.

I notice that the switch from BHP to HP occurs as X-plane goes from the loading window (progress bar being displayed) to the static menu page where you click to start the sim.

Additionally, BHP engages properly and remains engaged normally, switches properly back to Balanced Mode (BM) upon exit, when running Prepar3D and FSX. These two programs also go to a static menu. So, it may be just an X-plane glitch. Yes, I am a simmer.

Here is a key issue for you... BHP behaves properly when I start X-Plane in normal mode, The reported behavior only occurs when I start X-Plane in Virtual Reality (VR) mode!

I have set numerous Windows Mixed Reality (WMR) processes, Steam VR processes, and anything remotely related to VR to BHP. Unfortunately, it reverts back to HP.

I should have noted this before... apologies.

My work around is that I labeled MSI Afterburner (AB), my monitoring software, as BHP process. I start X-Plane in VR mode, wait til I hit the static menu page, then hit my hot key to start AB and BHP is engaged and performs normally including switching back to BM upon exit.

My VR rig is a Samsung Odyssey WMR headset. Thank you.
« Last Edit: November 22, 2018, 08:37:56 AM by Jdawg Jdawg »

Offline edkiefer

  • Volunteer User Moderator
  • Member#
  • *****
  • Posts: 1669
  • Gender: Male
Re: Process Lasso Not Staying In Bitsum HP Mode
« Reply #11 on: November 22, 2018, 09:05:31 AM »
Ok, Then it is Xplane changing plan, which is weird. That is the first time I have heard of a game doing that.
Things to look for though is if it has a launcher exe that then runs the X-planes game, but if you can't alter it to stick manually it probably going to be hard if they hardcoded it without some tricks.
I found this link to the game guide for X plane 11 VR and user shows using PL so this is odd.

http://www.ontheglideslope.net/2018/02/18/current-x-plane-11-vr3-setup-settings/

You could try a wildcard setting. here is an example of one for BFV the folder install path were all the exe are in the "*" in the path will enable performance mode for any of them running.
here sample
F:\Program Files (x86)\Origin Games\Battlefield V\*
note all the exe are in the Battlefield V folder and * means anyone will be tagged. I am assuming all X planes exe are in one folder.
I don't know if this will help.

Edit2: Is this a steam game, I see a steam path in your log is that part of your X plane game if so steam games are auto enabled.
So if Steam is being used at all then you don't need any path's or enabled X plane manually (induce performance mode).
Sorry for confusion your log is little hard to figure out.
« Last Edit: November 22, 2018, 09:42:36 AM by edkiefer »
Bitsum QA Engineer

Offline Jdawg Jdawg

  • New
  • *
  • Posts: 8
  • Gender: Male
Re: Process Lasso Not Staying In Bitsum HP Mode
« Reply #12 on: November 22, 2018, 11:50:10 AM »
Hello sir,

This is not a Steam version of X-Plane. Found the problem I think. It is related to SteamVR and the WMR programs and not X-Plane.

I went to Active Processes window of PL and made every entry related to VR, ie, SteamVR, holographic lens, vrcompositor, etc. BHP. Upon REstarting the game windows used BHP properly.

The only issue noted was that it did not return to Balanced Mode as it was prior to the BHP event, rather, it defaulted to Windows HP mode. Note that all VR related processes had been terminated when windows defaulted to the HP profile.

I am concluding that the issue is related to SteamVR and Windows Mixed Reality executables and not X-Plane. Thank you.
« Last Edit: November 22, 2018, 11:55:21 AM by Jdawg Jdawg »

Offline Jdawg Jdawg

  • New
  • *
  • Posts: 8
  • Gender: Male
Re: Process Lasso Not Staying In Bitsum HP Mode
« Reply #13 on: November 22, 2018, 09:31:56 PM »
Alternate Work A Round...

Copy Windows HP mode and rename HP1 then,

1. CMD
2. powercfg -list
3. Power Scheme GUID: 381b4222-f694-41f0-9685-ff5bb260df2e  (Balanced)
    Power Scheme GUID: 6aac2c07-b85f-4bd0-837c-486b482ebc66  (Bitsum Highest
    Performance)   
    Power Scheme GUID: 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c  (High performance) *
4. Change High Performance Value to that of Bitsum Highest Performance ie,
   
    Power Scheme GUID: 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c  (High performance) *
        becomes
    Power Scheme GUID: 6aac2c07-b85f-4bd0-837c-486b482ebc66  (High performance) *

In this way when uncommanded switch to Windows HP mode occurs it will be to BHP mode regardless. No need to solve the problem. Thanks.
« Last Edit: November 22, 2018, 09:34:54 PM by Jdawg Jdawg »

Offline Jeremy Collake

  • Administrator
  • Member#
  • *****
  • Posts: 5232
  • Gender: Male
  • The Lasso
    • Bitsum
Re: Process Lasso Not Staying In Bitsum HP Mode
« Reply #14 on: November 24, 2018, 03:20:04 PM »
That is a good fool-proof work-around!

I think your conclusion is essentially correct. The simple presence of SteamVR adds complexity to the rule application, resulting in this errant behavior.

A lot of work on the power management is coming in this beta series. While I need to study the your circumstances a bit more, I believe behavior here will be improved.

I am emailing you the requested upgrade link now.
Software Engineer. Bitsum LLC.

Offline idbirch

  • New
  • *
  • Posts: 5
Re: Process Lasso Not Staying In Bitsum HP Mode
« Reply #15 on: February 27, 2019, 08:10:13 PM »
I'm having this problem also and as far as I can tell, the problem is down to vrmonitor.exe which is essentially trying to replicate Process Lasso's behaviour, but in doing so just causing a mess.  I've just run a test scenario which seems to confirm it.  I have Process Lasso set to apply the Bitsum Highest Performance (BHP) profile when any game process is launched, however my Steam and SteamVR install folders are not set up for this so Steam and SteamVR themselves do not trigger a switch of profile by PL.

So, test scenario:

- PC is set to "Balanced" profile.  I launch a VR game shortcut
- PL correctly switches to BHP profile
- SteamVR automatically launches as Steam has detected a VR game running
- vrmonitor.exe now changes the power plan to 'High Performance', no doubt making a note that the current power plan is BHP
- I quit the game, PL reverts the power plan back to 'Balanced'
- I quit SteamVR, vrmonitor now sets the power plan to BHP as it thinks that was the preferred power plan before it changed to 'High Performance'

There are all sorts of variations on this sequence of events that are possible because you can launch SteamVR first, then launch games from within it.  You can also quit SteamVR and the game from within VR, who knows which process ends first and therefore which power plan wins out there!

I've posted a thread over on the SteamVR discussion board in the hope Valve can add an option to not mess with Power Profiles: https://steamcommunity.com/app/250820/discussions/4/1840188800787854771/ (https://steamcommunity.com/app/250820/discussions/4/1840188800787854771/)

In the meantime, I guess I'll try Jdawg's fix as it is becoming quite an annoyance.
« Last Edit: February 27, 2019, 08:17:47 PM by idbirch »

Offline idbirch

  • New
  • *
  • Posts: 5
Re: Process Lasso Not Staying In Bitsum HP Mode
« Reply #16 on: March 01, 2019, 07:21:06 PM »
Alternate Work A Round...

...
4. Change High Performance Value to that of Bitsum Highest Performance ie,
   
    Power Scheme GUID: 8c5e7fda-e8bf-4a96-9a85-a6e23a8c635c  (High performance) *
        becomes
    Power Scheme GUID: 6aac2c07-b85f-4bd0-837c-486b482ebc66  (High performance) *

I just got round to trying this, can you elaborate on how you change the GUID for a power plan?  Nothing in powercfg /? seems to mention the ability to do so.