Author Topic: Power Profile not restored after changed when Application /w associated default power profile is run  (Read 3649 times)

Offline chris635

  • Member++
  • ****
  • Posts: 270
  • Gender: Male
Hope this is fixed in next update  ;D


Chris

Offline BenYeeHua

  • Volunteer User Moderator
  • Member#
  • *****
  • Posts: 2243
  • Gender: Male
I moved this topic to BugTrack, as it is a bug. :)

Offline Jeremy Collake

  • Administrator
  • Member#
  • *****
  • Posts: 5207
  • Gender: Male
  • The Lasso
    • Bitsum
The 'force power profile on activity' setting was removed from Energy Saver, in an effort to simplify it's function.

So. that's why it's being reset.

That aside, it should function correctly, though certainly a bug is possible.

I am running extended tests now.
« Last Edit: August 03, 2014, 12:37:39 PM by support »
Software Engineer. Bitsum LLC.

Offline chris635

  • Member++
  • ****
  • Posts: 270
  • Gender: Male
Still losing the power profile set up. I have power saver set when idle for 720 seconds, and during regular use it is set for balanced. When steam or origin is opened I have it set to go to high performance, which it does. For some reason when I close out steam or origin (effectively turning off high performance) it drops back to power saver verses balanced. In order for it to work right again I have to shutdown process lasso, change my system to balanced then reopen process lasso (when process lasso is open and I change it to balanced, it still goes to power saver). It will then work right until I reboot my system. Any idea's?

Chris
Chris

Offline Jeremy Collake

  • Administrator
  • Member#
  • *****
  • Posts: 5207
  • Gender: Male
  • The Lasso
    • Bitsum

I am having some difficulties reproducing this, and I believe the issue is separate from the original reported issue of problems on update.

There are many possibilities. I'm trying to trace through the logic and find out how this could occur.
When you exit Steam, it should revert to the power profile that was active when Steam was entered.

I might guess that Power Saver was active when Steam was launched due to EnergySaver, *but* 720 seconds makes that unlikely, and you'd seemingly be at your PC when you invoked Steam.

There could be conflicting power profile rules. Do you have any other default power profiles set that might interfere? Any other power management software (probably not, but I have to ask)? Do you have any other PC optimization tools installed?

Like I said, I will continue working on this. Trying to figure out what could go wrong. It may not be resolved in the final build I'll be pushing out soon, but it's absolutely something that I will be focusing on as we ramp up Lasso dev to a whole new level.
Software Engineer. Bitsum LLC.

Offline Jeremy Collake

  • Administrator
  • Member#
  • *****
  • Posts: 5207
  • Gender: Male
  • The Lasso
    • Bitsum
Since it's so easily reproducible for you, what I may do is send a debug build. Then you can send me the debug log, and I'll know *exactly* what scenario is causing this.

Please hold and I'll publish such a debug build after this next update.
Software Engineer. Bitsum LLC.

Offline Jeremy Collake

  • Administrator
  • Member#
  • *****
  • Posts: 5207
  • Gender: Male
  • The Lasso
    • Bitsum
New debug build published here: https://bitsum.com/forum/index.php/topic,3642.0.html

As I proceed to investigate what is occurring here, the debug output may or may not be helpful. I may need to add more output, but we'll get there quickly.

I am still hoping to be able to reproduce the scenario locally, and/or deduce the likely cause of the discrepancy.

p.s. I do not believe it's the problem in your case, but any other third-party software that manages power profiles could interfere with Lasso.

Software Engineer. Bitsum LLC.

Offline chris635

  • Member++
  • ****
  • Posts: 270
  • Gender: Male
I am currently out of town for a few weeks. Before I left, I changed my temperature monitoring program and that seem to have helped. I will know for sure when I get back to do some extensive testing to be sure. I hope this will be okay.


Chris
Chris

Offline chris635

  • Member++
  • ****
  • Posts: 270
  • Gender: Male
Okay,
  I have a screen shot and csv log for you. I was playing crysis3 (high performance, cores unlocked). High performance mode is enabled by origin.exe. I stopped playing crysis and it dropped to power saver verses balanced. Seconds later it did switch to balanced (so at least it goes back to balanced now). Here is my power profile set up.

1. Balanced with cores parked under normal use.
2. High performance with cores unparked for games by using origin.exe or steam.exe.
3. Power Saver after my system is idle for 720 seconds.

Where do I send the csv log?
Chris

Offline Jeremy Collake

  • Administrator
  • Member#
  • *****
  • Posts: 5207
  • Gender: Male
  • The Lasso
    • Bitsum
You can email it to support@bitsum.com .

It looks like EnergySaver induced Power Saver. I guess you weren't actually idle though... Are you using any sort of game controller?
Software Engineer. Bitsum LLC.

Offline chris635

  • Member++
  • ****
  • Posts: 270
  • Gender: Male
Yes I am using a game controller but I have power set to ignore when a game is played. Email on the way.

Chris
Chris

Offline Jeremy Collake

  • Administrator
  • Member#
  • *****
  • Posts: 5207
  • Gender: Male
  • The Lasso
    • Bitsum
Ah! I believe what occurred is a quirk/bug in EnergySaver. When the game terminated, it kicked in for a second - thinking you'd been idle all that time (even though you weren't).

I will evaluate the code and get back to you.

Software Engineer. Bitsum LLC.

Offline chris635

  • Member++
  • ****
  • Posts: 270
  • Gender: Male
Chris

Offline Jeremy Collake

  • Administrator
  • Member#
  • *****
  • Posts: 5207
  • Gender: Male
  • The Lasso
    • Bitsum
I determined the cause to be as I surmised.

First, your game controller was not treated as input. That is something I'll need to address.

Coupled with the termination of the game, EnergySaver briefly entered the idle 'power save' profile, thinking you had been idle when the game exited.

Since it immediately returns to the prior profile, and the default application power plan is appropriate restored, I'm deferring an adjustment to the next build.

In other words, it's not a big deal, and so I don't want to take any chances making last minute adjustments to v6.9.2.2.

But it *will* get addressed in the near future!

Software Engineer. Bitsum LLC.

Offline lmstearn

  • Basic
  • **
  • Posts: 19
  • Gender: Male
    • My_Very_First_Home_Page
Just a necro "heads up" request: when playing Oblivion and exiting the game without incident as seen in the first entry of the log, the default power plan is resumed.
If it crashes (usually C0000005), then for some reason the Process Lasso logs the termination event, but the default power plan is not resumed. Refer to the first crash at 15:08 in the log.
However the extra complication in this case is that two processes obse_loader and Oblivion running concurrently are both configured as HP.
Edit: Did it again- this time no crash- but Oblivion seemed to take a longer time than usual to close. A very old, and slightly buggy program!
NB: when attaching the log here, got:
Quote
The attachments upload directory is not writable. Your attachment or avatar cannot be saved
Might be because this is an old post, sorry.
Thanks for reading.
« Last Edit: June 02, 2018, 10:59:32 AM by lmstearn »