Bitsum Community Forum

Release Announcements => Bitsum Technologies Company Announcements => Topic started by: edkiefer on June 19, 2014, 06:39:42 PM

Title: PL GUI cpu% useage
Post by: edkiefer on June 19, 2014, 06:39:42 PM
I am posting here cause I am not sure, but from memory PL GUI I think used to use about or little more than MSI AB or other monitoring app .

But with default setting I am seeing 10x more in CPU time , heavily dependent on whether PL is minimized or not but even in tray it seems heaver usage than what i remember in past .

Trying to see if I can track down what it is, I have disabled log , module options but still seems a lot .
Title: Re: PL GUI cpu% useage
Post by: BenYeeHua on June 20, 2014, 11:32:09 AM
Quote
But with default setting I am seeing 10x more in CPU time , heavily dependent on whether PL is minimized or not but even in tray it seems heaver usage than what i remember in past .
How much?

At here, with I5-3210m, I get 0.16 CPU usage per second only while minimized, and 1.xx CPU usage while showing.
Title: Re: PL GUI cpu% useage
Post by: edkiefer on June 20, 2014, 11:48:00 AM
That sounds about same, I even run refresh of 2sec .
I just thought it was much lower before . seems so high when open .
I have graph off too .

i5-3570k@4.2

minimized PE shows almost constant 0.04 and PL open about 1.0 avg
BTW, that is way more than Process Explorer , that only goes to 0.30 with it open , running and it has fast refresh/updating .
Edit: I have update set to 1sec on PE so it is same as default PL but looks faster .
Title: Re: PL GUI cpu% useage
Post by: BenYeeHua on June 21, 2014, 10:38:58 AM
Yup, the GUI can optimize, but I think continue optimize it might not the right choose, and a rewrite might be the choose, as GUI sometimes can be buggy.
Maybe it is time to making it more simper, or more simper to access the info that you need. ;)

For PE, not sure about it, but you know who write it. :)